Library not loaded: @rpath/WebRTC.framework/WebRTC

I tried all your brew steps. still am getting this error

Hi, thanks for the report. Can you give us some more information about your configuration?

Are you using CocoaPods to integrate SendBirdCalls?
If so, is it properly linked with your main project, and did you install SendBirdWebRTC with git lfs configured on your environment?

The error is caused when the WebRTC.framework is not loaded with the project, which may be due to the framework not being included as a target in CocoaPods.

If you are using CocoaPods, you could try deintegrating CocoaPods and retry installing by running the following commands:

pod deintegrate
pod install

on your project’s directory.

Please reach out if this doesn’t resolve your problem! :slight_smile:

@mininnyam using cocopods only.
pod deintegrate
pod install

I tried this. still cant

I tried this step also. cant

@GoNext_Info_Solution

Can you verify the version of your macOS and Xcode?

It also would be helpful if you could provide screenshots or informations about your project’s build phase and downloaded WebRTC framework. Is the size of the loaded framework over 800MB, and is SendBirdWebRTC correctly included as a Dependency in Pods project?

Thanks.

macOS version - 10.15.5
Xcode Version - 11.5

No the framework is in KB only.

The framework’s size should be over 800MB if it is properly installed. Can you follow the steps to install git-lfs and install the whole framework binary?

Can you try the troubleshooting guidelines as shown in the screenshot (i.e. brew install git-lfs) in terminal, and send the logs here?

Thanks.

Screenshot 2020-06-26 at 11.39.59 AM

Can get it resolved?

@GoNext_Info_Solution Did you try brew link git-lfs and see if it fixes your problem?

1 Like