Inconsistent VoIP notifications

[Problem/Question]
// Detailed description of issue.

I am using the ios quickstart sample project(GitHub - sendbird/quickstart-calls-directcall-ios: iOS sample for Direct Call of Sendbird Calls, guiding you to build a real-time voice and video calls quickly and easily.) to test voip notifications in a controlled environment, as my other project also has issues with voip notifications but to eliminate any code issues i chose to test the setup with the sample project.
I have edited all the bundle id references to a custom one so I can run the code on a physical device. I have updated the project with the appropriate AppID. I have Calls enabled in Dashboard.
I have signed in on XCode. I have created a VoIP Services certificate specifically for that bundle id. Made it trusted in Keychain. Exported it with to p12 without setting a password. Then imported it in Sendbird Dashboard - APNs for the correct app. It says - " VoIP notifications ON".
I ran the app on a physical device, then signed in with a user - checking the logged in user shows they have the push notification token for Calls. Then trying to call that user either from the web, Call Studio or the Sendbird Calls app(downloaded last week) on an Android phone when i try to call the iPhone i ran the app on, no VoIP notification. After I minimize the app on the iPhone for two seconds, and open the app again, only then I receive the VoIP notification and can accept the call. When accepting it works properly. When I call from the iPhone to the other device(the Android mentioned above) it always rings.


// If problem, please fill out the below. If question, please delete.
[SDK Version]
// What version of the SDK are you using?
The one in the from the repo - GitHub - sendbird/quickstart-calls-directcall-ios: iOS sample for Direct Call of Sendbird Calls, guiding you to build a real-time voice and video calls quickly and easily.

[Reproduction Steps]
// Please provide reproduction steps and, if possible, code snippets.
Download repo.
Replace bundle id references in all places with something valid.
Replace AppId with the proper id.
Setup voip services certificate in Apple certificates → make it trusted in keychain → export it without password → add it to sendbird dashboard - push notification.
Run the app from the repo on a physical device(iphone 13 - ios 17.3.1), on a signed in Xcode.
Sign in with a user
Verify user has a valid Calls push token
Call that user from any other place - web, CallStudio or Sendbird Calls app downloaded from the respective store(in my case Google play)

[Frequency]
// How frequently is this issue occurring?
Consistent

[Current impact]
// How is this currently impacting your implementation?
It is impacting us heavily on the other project as we have the implementation ready, but cannot continue development as it we cannot make it work.

@Tyler @taha.saghir Sorry to tag you directly, but do you have any idea what might be the issue? Or can you point me to someone I can further contact about this?

@festersson @Koko12 Hi there.

Thanks so much for the detailed explanation.
Please might I ask if you can send me a couple of call_ids where this issue happens.
With the call ids myself or our Calls engineers can potentially trace what is happening in conjunction with the sample app’s code.

Here are some call ids:
18ADFCCD-B1FC-41FE-813F-DE2B177CC971
97851A57-EF6E-433A-818E-2AEDA32AC307
9266825E-8877-4535-A338-83CB5A8A03FB
AA466ACF-E420-464A-9234-33BE0A5599A2

The caller user is from Calls Studio, the callee is on a physical device running the quickstart app. Let me know if there is anything else I can assist with to solve this.

Thank you for looking into this.

Hi there.

I can see that none of the push notifications sent for the Calls listed above succeeding. The reason that you can get notification on app moving to the foreground again is likely because the signal came through the connected websocket.

For all of the push notifications there are two types of errors.

After researching them. I think there might be an issue with our calls server on eu1. I’ve engaged our calls engineers and will keep following up with them on a fix.

I’m so sorry for this case and will keep you updated.

@festersson @Koko12 Hi again. I trust you are well.

I mentioned to @Koko12 Via DM about a possible work around. I’m wondering how things are going please?