Minor package version incompatibility?

I was upgrading from sendbird-uikit v1.0.2 -> v1.0.7 and saw errors in the console around sdk.getAllEmoji being undefined. From reading through the release notes for sendbird and sendbird-uikit, it looks like this function was added in sendbird v3.0.123.

When I did a yarn install on the new version of sendbird-uikit, it added the following package manifest to my yarn.lock file: https://registry.yarnpkg.com/sendbird-uikit/-/sendbird-uikit-1.0.7.tgz#148a6bd2f9d63a17ba064481c0b5ae3fc4b7d17c

Looking in that manifest, I see that sendbird is listed as a peer dependency of ^3.0.123 (correct), but a dependency of ^3.0.122 (missing several functions).

I was able to work around this by pinning the version in my package.json file, just wanted to flag it in case anyone else was running into issues.


P.S. Let me know if this is not the correct venue for reporting issues in the future.

1 Like

Hello Kyle, thanks for the report. We missed this problem(npm :frowning_face: )
Will update it ASAP

This is the correct platform to report

we released a version 1.0.8 with the fix