Compile errors when upgrading from uikit-react 3.4.7 -> 3.4.8 or 3.6.0

We’re currently using React UIKit 3.4.7

There seems to be an issue with word wrapping on the message body and was told to upgrade to 3.4.8.

We upgrade to latest build and it gives us this error.

Errors don’t make sense to me. So I decided to upgrade to 3.4.8 and it’s still throwing this error with a do a npm install. Any clue on what’s going on. Did something go missing?

I am getting a very similar error and unable to use sendbird at all because it fails at compile time

Fix for me was changing from "@sendbird/uikit-react": "^3.4.6" which is equivalent to 3.4.x and changing to "@sendbird/uikit-react": "3.4.7" which is a pinned dep

Looks like they hotfixed it. Update to 3.6.2,

I had asked support a question about it last night and they saw there was an issue so they got around to fixing it. Hope this solves it for others.


Thank you for updating the information about our fix(link).
As a note, this compile issue is specific to Webpack.