Incoming call notification is not coming

Incoming call notification not coming
When I am making a call from one device to another on receiver side incoming call notification is not coming only missed call notification is coming. One of my another developer is also using the same code but on their system code is working fine. So I just want to know that is there any environment settings that I need to check/configure in my system?


For iOS and Android, could you check if the push cert and device push token are registered normally?

Which device has the problem and which device hasn’t?

Thank you for the reply. I think it’s not an FCM problem, but this is an issue regarding that the call reception is not working in most PC emulator environments.

It is not related to FCM because FCM missed call notification works fine after the call ends. Also, the call reception works fine when test-distributed on google console and when the apk is built and installed in real device.

The problem is that the call reception is not working ONLY in the develpment environment.

Below is the list of test situation that we have went through so far:

  1. Only 1 PC can receive calls on the android emulator, among 6 different PCs. (Tried in the same branch of GitHub, so it is not the issue of RN code)
  2. The other 5 PCs cannot receive calls on both Emulator in PC (virtual) and physical device.
  3. The reception works well when apk is built and installed on a real device. However, in this case, the log of the modified code cannot be checked in real time, and the apk must be built and installed on the actual device after each and every modification.
  4. Call reception works even when test-deployed in google play store.
  5. It is not an android studio version problem.
  6. Device: nexus5X (or 5) API 30 / pixel XL API 33
  7. It’s not a npm or node version issue.
  8. It’s not a library version problem in react native.
  9. It’s not a Windows 10 or 11 version issue either.
  10. I have tried - clean project, rebuild project, invalidate caches, wipe data, cold boot in android studio, but nothing worked.

Other than the above issues, is there any other steps that we need to check/follow when setting up the development environment for RN - Android Emulator?

Hi @itruck008, could you check if the emulators are Google APIs enabled?

1 Like

We’re using the beta version of Sendbird may be this issue is because of that, so is there any better way to migrate this to official SDK with minimal changes?

Hi @itruck008.
That is not our beta SDK, and not many APIs are supported, so it seems there will be no big problem even if you migrate them manually.

Our official SDK is here @sendbird/calls-react-native - npm
GitHub - sendbird/sendbird-calls-react-native: Sendbird Calls SDK for React-Native


Incoming calls are coming now. We’re using wrong firebase server key for dev project. It is working now.