Invalid APNS certificate

Hi. I want to enable push notifications for my app. The problem is that I can’t upload the certificate.
I have tried:

  • uploading p8 for dev/prod for one app app
  • uploading p8 for dev/prod for the other app
  • uploading p12 for dev/prod for both apps

Every time I get Invalid APNS certificate error

Hello @Andrew74

The .p12 typically has to be exported including the key.

It’ll say “export 2 items”, but it merges them as a proper .p12.

I’m sharing a guide a detailed guide for your reference: guidelines-ios/How to generate iOS certificate at master · sendbird/guidelines-ios · GitHub

You can refer to step 3 here and do not provide an export password when prompted : Register push notification credentials | Chat iOS SDK | Sendbird Docs

Let me know if this helps.

Hi @Chinmaya_Gupta.
This doesn’t help, the problem is not in generating a certificate, I know how to do it.

The problem is that I can’t upload the certificate. Every time I do that I get “Invalid APNS certificate error”

I’m having the same issue. Every time I add my certificate for iOS push notifications I get an error:
Invalid APNS certificate.

After creating a prod and dev certificate through Apple, I tried to set up the certificate using a P12 certificate. I also tried uploading a P8 Apple key and setting up the right values for the team ID, key, and bundle ID. In all cases, I got the same error.

Is there any chance the problem is on sendbird’s side here?


The problem is 100% on sendbird’s side. Now I don’t event have the choose file dialog

@Chinmaya_Gupta Can we have some guidance here. I move around quite well with Apple certificates and we’re both lost here. Thanks in advance! Happy to provide more screenshots or info about the account if needed

Hi @Jordi_p_m,

Sending you a direct message to request some information.

1 Like

Hi @Andrew74

DM’ing you as well for some additional information.

1 Like

Hello @Jordi_p_m @Andrew74

This should have been resolved now. Can you please test it now?

1 Like

It does work. thanks a lot for the support!

Hi @ Chinmaya_Gupta!
It works via api, but web ui is still not responsible. I am pressing “choose file” button and nothing happens
I have google chrome and a couple of days before it used to work.

Posting an update on this thread.

The issue has been resolved by our engineering team. If you are still experiencing issues uploading an APNS cert, please let us know.