QuickStart Call Github Sample. Incoming Video is not showing up


Building and Running this code on two of our device to see how incoming and outgoing works during a video call.
On the receiver side. remote video of the caller is not appearing.

// If problem, please fill out the below. If question, please delete.
[SDK Version]
// What version of the SDK are you using?
// SendBird SDk
implementation ‘com.sendbird.sdk:uikit:3.5.0’
implementation ‘com.sendbird.sdk:sendbird-calls:1.10.6’

[Reproduction Steps]
// Please provide reproduction steps and, if possible, code snippets.
Just build the sample and run them on two android devices. call to one another.
On incoming side, video will come blank. You try calling from other device and behaviour will also appear.

// How frequently is this issue occurring?

100% reproducible every time

[Current impact]
// How is this currently impacting your implementation?
We are blocked with the integration of sendbird call in our product

Hello @Rohit_Sharma I’m Elliot,

After building the sample, did you grant all the necessary permissions such as camera access, nearby device scanning permission, and other permissions on each device?

Yes, i gave all the permission.

If i try to switch the devices. Like now calling from the 2nd to 1st. Now on 1st device remote view do not come. So problem is on the receiving side.

We have pulled this entire quickstart code into our project. First i thought it could be a problem with my integration. But then even on sample code. Behaviour repeats

If i try with 1 device and call studio from dashboard. Then it works fine. But not from one device to another.

Call studio and Sample app are same project, so it’s a bit difficult to figure out why only the Sample app isn’t working. Is it correct that there is blank screen and the sound can be heard?

To understand the situation in more detail, the following steps may be necessary. Could you set the LoggerLevel to INFO and check the log messages of the Receive device? The log should cover the period from the time the push was received to when the black screen is displayed after pressing the accept button for the push.


public class BaseApplication extends MultiDexApplication {
    public boolean initSendBirdCall(String appId) {
            if (SendBirdCall.init(context, appId)) {

Let me know if you are able to see logs below

I can send over email as well if you want.

Yes sound comes in properly as audio call works also. Only the video is not working. On the receiving side.

Is the sample app from quickstart call sdk github is working for you. Like have you tried that with real devices to call each other ?

Would you be able to send me the log via “elliot.choi@sendbird.com”?
Additionally, the sample is working on my devices. The devices are Samsung S20 with Android OS 13 and Samsung Z flip2 with Android OS 12. (it is also working on the emulator.)

I received the Log you sent via email. Thank you.
Could you please let me know what Android version the device used for testing?

I have shared the device details also to you on your email.

I am using OnePlus 9 5G phone, Android 11 on it and other side as emulator also is not working.

I also tested with Samsung Latest Android device as well.

Thank you for your response. You mentioned that you are also experiencing the same issue with the sample we provided. Could you please send us the sample as an apk file? We need to check if there is any issue during the build process.

Let me know if this build is accessible to you

Hi @Rohit_Sharma
When I installed the app with the apk you sent me, it worked fine on my devices. I think the issue is most likely related to the network or permission settings. Can you tell me what type of network environment each device is using (WiFi, LTE, etc.)?

I would like to request another test using the apk you sent me, instead of building the app directly in Android Studio. Please install the app using the apk and test it again. Also, please check if the camera permission is enabled in the application settings. (I tested the app by installing the apk through drag & drop on an Android Studio emulator since it was not installed on an actual device due to package installation issues.)

It didn’t worked guys. I checked even on 4G network. Gave all the permissions as well.

Confirming it worked on a different set of device. This is strange as whats video call work fine on this device.

Only on the latest call sdk version this problem is resolved