Only receiving Notification, not call of upcoming calls

I have implemented the latest (version 1.2.0) sample app example in my application and everything works great except the upcoming call alert. In the latest version the receiver only receives a notification of upcoming call even if the phone is not in use.
How can we receive the notification like whatsapp does when phone is in use and full screen calling interface when the phone is not in use??

@kckern @Alex_Preston can you guys please help with this

Hey @Nemi what SDK are you using? iOS or Android? Could you also provide a snippet of how you are handling incoming calls?

@Alex_Preston we are using Android SDK. we have added the exact code as shown in quickstart call sample app( version 1.2.0) i.e.
https://github.com/sendbird/quickstart-calls-android
I also tried your sample app and it also receives only notification doesn’t matter if the app is in foreground or background.
I couldn’t find the full screen layout code in the sample app.
Have you guys added the full screen incoming call layout or is it just the call notification with option to accept or reject in the latest sample app code?

Ahh, I get it. I was using 1.1.3 sample app, which does show how to display full screen notifications as you can see in image attached. Hadn’t pulled 1.2.0 to see that they changed the implementation. If you want a rough idea as to how it used to be done, I think you can reference this commit. Essentially in the SendBirdCall.addListener of the BaseActivity, they have a call ActivityUtils.startCallActivityAsCallee(context, call); this launches the Activity for either Video call or Voice call(Based on which it is, the appropriate UI will be displayed). Does this give you a better idea?

@Alex_Preston in our apps last version we were using the 1.1.3 sample app and as per your comment it does have upcoming call screen activity but it requires overlay permission to show the upcoming calls. Is there any way we can show upcoming call screen without requesting the overlay permission as our customers are not happy with providing this permission? That is the reason i was updating the version from 1.1.3 to 1.2.0 but i guess the latest sample app code has it’s own limitation.

1 Like

Thanks for the additional context. I think it depends on the situation, you can see the list of ‘exceptions’ to the rule here. In general I don’t think there is an easy way around this without explicitly granting:

<uses-permission android:name="android.permission.SYSTEM_ALERT_WINDOW" />

Which is why our new sample removed it. So I would say no there isn’t really a way to get around it.