Error on installing SendBirdWebRTC with pod install

Hi, I keep getting errors on installing SendBirdWebRTC with ‘pod install’. The errors are shown as below:

[!] Error installing SendBirdWebRTC
[!] /usr/local/bin/git clone GitHub - sendbird/sendbird-webrtc-ios /var/folders/0x/8r1db9vx17d5mj7sy843kskh0000gn/T/d20210929-41523-11vgb6z --template= --single-branch --depth 1 --branch 1.3.0

Cloning into ‘/var/folders/0x/8r1db9vx17d5mj7sy843kskh0000gn/T/d20210929-41523-11vgb6z’…
Note: switching to ‘bd0e1895d0f01d1d8a50ba17e6d8b3c6390026d5’.

You are in ‘detached HEAD’ state. You can look around, make experimental
changes and commit them, and you can discard any commits you make in this
state without impacting any branches by switching back to a branch.

If you want to create a new branch to retain commits you create, you may
do so (now or later) by using -c with the switch command. Example:

git switch -c

Or undo this operation with:

git switch -

Turn off this advice by setting config variable advice.detachedHead to false

Downloading WebRTC.framework/WebRTC (1.2 GB)
Error downloading object: WebRTC.framework/WebRTC (1d51e4b): Smudge error: Error downloading WebRTC.framework/WebRTC (1d51e4b9ddf3e3ec92107a0bcb6542bb8829ad0c60af16df9c89dafbe214d45d): batch response: This repository is over its data quota. Account responsible for LFS bandwidth should purchase more data packs to restore access.

Errors logged to /private/var/folders/0x/8r1db9vx17d5mj7sy843kskh0000gn/T/d20210929-41523-11vgb6z/.git/lfs/logs/20210929T113810.708836.log
Use git lfs logs last to view the log.
error: external filter ‘git-lfs filter-process’ failed
fatal: WebRTC.framework/WebRTC: smudge filter lfs failed
warning: Clone succeeded, but checkout failed.
You can inspect what was checked out with ‘git status’
and retry with ‘git restore --source=HEAD :/’

Please help on this issue ASAP. Thanks!

Hi @Doyeong_Kim ,
Thanks for reaching out. We are looking into solving this right now but it may take some time before it is available for download again.
For now, could you please try downloading the binary framework from Github release directly instead of using Cocoapods to install WebRTC Framework manually? Download is available at Release 1.3.0 · sendbird/sendbird-webrtc-ios · GitHub.

Hi, thanks for quick reply!

Btw, could you kindly provide any guide documents on manual installation? Thanks.

Here is a guide for manual setup GitHub - sendbird/sendbird-calls-ios: A guide of Sendbird Calls SDK for iOS for an engaging voice and video call experience.. While this is for SendBirdCalls, you can do the same with the SendBirdWebRTC framework as well :slight_smile: Please let me know if you have problems using this method.

Hi, the project is clonned from our git server and i get the same error whenever I try ‘pod install’ even after I add the framework manually, since our git has SendBirdWebRTC in podfile. Is there any solutions?-? Thanks!

Hi again,
Actually, we fixed the issue with Git LFS, so you will be able to install the framework with cocoapods now.
Can you please try installing again with cocoapods as usual, and let us know if it works?

thanks,

Hi, yes it works now perfectly! Thanks for your support :slight_smile: