SendBirdCalls SDK

I installed the SDK with CocoaPods
but, The framework size does not exceed 800 MB.
I tried troubleshooting step by step, but it didn’t work
please give me a solution

Development environment

  • macOS Big Sur 11.3.1
  • Xcode 12.5

Hey @MACAKM,

Thanks for reporting this. Our Engineering team is taking a look. As soon as we have an update on that, I’ll let you know.

Hello @MACAKM, thanks for reporting this issue :slight_smile:

Did you try the troubleshooting guide here and correctly removed CocoaPod’s cache after installing git-lfs?

If reinstalling and reconfiguring is not working out at the moment, could you try downloading the SendBirdWebRTC framework from our public repository directly? If you’re using cocoapods with your project, you can copy the downloaded framework into PROJECT_DIRECTORY/Pods/SendBirdWebRTC and clean build the project.

Thanks!

1 Like

Hello~ thank you for the reply

I tried the steps below.

  1. Cleared all caches of CocoaPods by following the troubleshooting guide
pod cache clean --all
rm -rf ~/Library/Caches/CocoaPods/*
rm -rf ~/Library/Developer/Xcode/DerivedData/*
pod deintegrate
pod setup
  1. pod install

However, since the size does not exceed 800MB, the framework is downloaded from the public repository provided. copied here

PROJECT_DIRECTORY/Pods/SendBirdWebRTC

but i get the same error

Hi, thanks for the clarifications!

Did you install git-lfs by running brew install git-lfs before running the steps you described?

Also, it is very weird that the error is still persisting even after manually downloading the framework from github. Did you clean build the project after copying the framework to the pods directory?
Could you please give us more detail about the error message, and where it’s occurring from?

This is the log when brew install git-lfs

kmbang@Macintoshs-MacBook-Pro maca-ios % brew install git-lfs

Updating Homebrew...

==> **Auto-updated Homebrew!**

Updated 1 tap (homebrew/core).

==> **Updated Formulae**

Updated 66 formulae.

Warning: git-lfs 2.13.3 is already installed and up-to-date.
Just in case, I did a brew reinstall git-lfs

So I did brew reinstall git-lfs

kmbang@Macintoshs-MacBook-Pro maca-ios % brew reinstall git-lfs

==> **Downloading https://ghcr.io/v2/homebrew/core/git-lfs/manifests/2.13.3**

Already downloaded: /Users/kmbang/Library/Caches/Homebrew/downloads/b5ae980db938afe1eca8e8ec2f493a0f6b0b040a959e811147b228912f389846--git-lfs-2.13.3.bottle_manifest.json

==> **Downloading https://ghcr.io/v2/homebrew/core/git-lfs/blobs/sha256:153252f96cb3d77c2980f18c5eab59**

Already downloaded: /Users/kmbang/Library/Caches/Homebrew/downloads/6644a36250f68ee2eb597e49a472afd74a12ea56dd1d0a7b2709d63f8f6db447--git-lfs--2.13.3.big_sur.bottle.tar.gz

==> **Reinstalling** **git-lfs**

==> **Pouring git-lfs--2.13.3.big_sur.bottle.tar.gz**

==> **Caveats**

Update your git config to finish installation:

Then I went through the troubleshooting steps and did a pod install. And I manually downloaded the framework and copied it to the pods path.

When building on a real device, Build Succeeded appears, but only the following log is checked.

Looking about the error, it seems to be caused by using SPM due to some issue with code signing. Referenced here.

It seems like it was fixed in Xcode 12.3… do you have other dependencies on your project? Does the issue disappear when you remove SendBirdCalls dependency?

If I remove the SendBirdCalls dependency the problem goes away and the app works fine

That is odd… This is something that I haven’t seen

If you could provide us an example project where the issue reproduces, or more specific steps and configurations to reproduce this issue, it would greatly help us debug the issue.

Thanks :slight_smile:

I created a new project and tried it.

After installing with brew install git-lfs, I installed SendBirdCalls with CocoaPods. But it didn’t.

So I followed the troubleshooting guide and cleared all caches, manually downloaded the framework (Release 1.3.0 · sendbird/sendbird-webrtc-ios · GitHub)and copied it to the Pods path, but it still doesn’t work.

My development environment is as follows

  • MacOS : Big Sur 11.3.1
  • Xcode : 12.5

the error is as below

Hello @MACAKM,

We found out that there was one step missing in our trouble shooting guide which might have caused this issue.
git lfs install

Can you try running the above command after brew install git-lfs then try again after removing all the cache and deintegrating the Pod project?

Thanks :slight_smile:

2 Likes

After doing git lfs install the problem was solved. Thanks for your help. :+1:t2:

1 Like